当前位置: 首页 > 股票软件公式 > 飞狐公式 > 文章 当前位置: 飞狐公式 > 文章

927sb.com:飞狐源码:分时主图,macd结构副图

本文地址:http://607.yi155.com/xuexiao/news/1293.html
文章摘要:927sb.com, 三个否极泰来 你咋了笑着开了个玩笑。

点击: 次    来源:顶尖财经    作者:股市狙击 中原彩票网正规 + 大

分时主图:

分时有压力位有支撑位,有买点提示B,还有九转!
适用飞狐软件,不是通达信公式。
 

HH:=MAX(DYNAINFO(3),DYNAINFO(5));
 LL:=MIN(DYNAINFO(3),DYNAINFO(6));
 PP:=HH-LL;
 阻力:LL+PP*7/8,Precision2,COLOR00DD00,LINEDOT;
支撑:LL+PP*0.5/8,Precision2,COLORFF80FF;
 STICKLINE(CROSS(支撑,C),支撑,(支撑+阻力)/2,1,0),COLORFF00FF; 
 STICKLINE(CROSS(C,阻力),阻力,(支撑+阻力)/2,1,0),COLORFF8000; 
 DRAWTEXT(LONGCROSS(支撑,C,2),支撑*1.001,'↑B'),LINETHICK16,COLORred;
 DRAWTEXT(LONGCROSS(C,阻力,2),C,'↓S'),LINETHICK16,ColorGreen;
 
A1:=C>REF(C,4);A2:=C<REF(C,4);
T1:=A2 AND REF(A1,1);
T2:=A2 AND REF(T1,1);
T3:=A2 AND REF(T2,1);T4:=A2 AND REF(T3,1);
T5:=A2 AND REF(T4,1);
T6:=A2 AND REF(T5,1);T7:=A2 AND REF(T6,1);
T8:=A2 AND REF(T7,1);
T9:=A2 AND REF(T8,1);
T10:=A2 AND REF(T9,1);
DRAWTEXT(T6,L,'6'),COLORMAGENTA;
 
DRAWTEXT(T7,L,'7'),COLORMAGENTA;
DRAWTEXT(T8,L*0.99,'8'),COLORMAGENTA;
 
DRAWTEXT(T9,L*0.99,'9'),COLORRED;
 
AAE:= WINNER(C+C*15/100)*100;
BBE:= WINNER(C+C*0/100)*100;
 
CCE:= AAE-BBE;
DDE:= (WINNER(C-C*0.1/100)-WINNER(C-C*15/100))*100;
 
EEE:= CCE<3 AND DDE<0.5 AND O>LOW;
AE1:= DYNAINFO(6);B1:=C<REF(C,4);
B2:=C>REF(C,4);
D1:=B2 AND REF(B1,1);
D2:=B2 AND REF(D1,1);
 
D3:=B2 AND REF(D2,1);D4:=B2 AND REF(D3,1);
D5:=B2 AND REF(D4,1);
D6:=B2 AND REF(D5,1);
D7:=B2 AND REF(D6,1);D8:=B2 AND REF(D7,1);
D9:=B2 AND REF(D8,1);
D10:=B2 AND REF(D9,1);
DRAWTEXT(D6,H*1.01,'6'),COLORYELLOW;
 
DRAWTEXT(D7,H*1.001,'7'),COLORYELLOW;
DRAWTEXT(D8,H*1.001,'8'),COLORYELLOW;
 
DRAWTEXT(D9,H*1.001,'9'),COLORYELLOW;




macd结构副图:

钝化、结构形成、消失一目了然。
另外加上了RIS指标。好不好用,你自己看。

适用于飞狐软件,不是通达信公式。( 顶尖财经 股票学院: http://607.yi155.com )


DIF:(EMA(C,N)-EMA(C,P1)),Precision2,COLORFF8000,LINEDOT;
DEA:EMA(DIF,P2),Precision2,COLOR4080FF,LINEDOT;
MACD:(DIF-DEA)*2,Precision2,LINETHICK0;
{MACD底部结构预警}
死叉:=CROSS(DEA,DIF);
N1:=BARSLAST(死叉);
N2:=REF(BARSLAST(死叉),N1+1);
N3:=REF(BARSLAST(死叉),N2+N1+2);
{DRAWTEXT(死叉,DIF*1.05,'↓M死'),COLORF0DC97;}
CL1:=LLV(C,N1+1);
DIFL1:=LLV(DIF,N1+1); 
CL2:=REF(CL1,N1+1);
DIFL2:=REF(DIFL1,N1+1);
CL3:=REF(CL2,N1+1);
DIFL3:=REF(DIFL2,N1+1);
PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
MDIFB2:=INTPART(DIF/POW(10,PDIFL2));
MDIFB3:=INTPART(DIF/POW(10,PDIFL3));
直接底背离:=(CL1<CL2 ) AND (MDIFB2>MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);
隔峰底背离:=(CL1<CL3 AND CL3<CL2 ) AND (MDIFB3>MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);
B:=(直接底背离 OR 隔峰底背离);
BG:=((MDIFB2>REF(MDIFB2,1))*REF(直接底背离,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背离,1)),LINETHICK0;
底背离消失:=(REF(直接底背离,1) AND DIFL1<=DIFL2 ) OR (REF(隔峰底背离,1) AND DIFL1<=DIFL3);
STICKLINE(B OR BG,DIF,DEA,3,0),ColorYellow;{柱线带}
DRAWTEXT((B AND COUNT(B,2)=1),(DIF*1.5),'钝化'),coloryellow;
DRAWTEXT(FILTER(BG,10),(DIF*1.5),'形成'),colormagenta;
DRAWTEXT(FILTER(底背离消失,10),MACD*1.1,'消失'),colorgreen;
STICKLINE(BG,0,(DIF+DEA)*0.6,4,0), ColorRED;{柱线}
金叉:=CROSS(DIF,DEA);
M1:=BARSLAST(金叉);
M2:=REF(BARSLAST(金叉),M1+1);
M3:=REF(BARSLAST(金叉),M2+M1+2);
DRAWTEXT(金叉,DIF*1.05,'↑M金'),COLORRED;
CH1:=HHV(C,M1+1);
DIFH1:=HHV(DIF,M1+1);
CH2:=REF(CH1,M1+1);
DIFH2:=REF(DIFH1,M1+1);
CH3:=REF(CH2,M1+1);
DIFH3:=REF(DIFH2,M1+1);
PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);
MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));
PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);
MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
MDIFT2:=INTPART(DIF/POW(10,PDIFH2));
MDIFT3:=INTPART(DIF/POW(10,PDIFH3));
直接顶背离:=(CH1>CH2 ) AND (MDIFT2<MDIFH2) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,1);
隔峰顶背离:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT3<MDIFH3) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);
T:=(直接顶背离 OR 隔峰顶背离);
TG:=((MDIFT2<REF(MDIFT2,1))*REF(直接顶背离,1)) OR ((MDIFT3<REF(MDIFT3,1))*REF(隔峰顶背离,1));
顶背离消失:=(REF(直接顶背离,1) AND DIFH1>=DIFH2 ) OR (REF(隔峰顶背离,1) AND DIFH1>=DIFH3);
STICKLINE(TG,0,(DIF+DEA)*0.6,3,0), COLORE79A32;{柱线}
STICKLINE(T OR TG,DIF,DEA,5,0),colorgreen;{柱线带}
DRAWTEXT(FILTER(TG,20),(DIF*1.4),'形成'),colormagenta;
DRAWTEXT(FILTER(顶背离消失,20),MACD*1.2,'消失'),colorgreen;
 FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);
 FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;
 FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1);
 FH4:=FH1 AND FH2 AND ABS((DIF-DEA)/C)<0.018;
 FH5:=FH1 AND FH2 AND MACD<0.10;
二次翻红:(FH3 OR FH4 OR FH5),COLORRED,NODRAW;
 DRAWTEXT(二次翻红,MACD*1.5,'←复红'),COLORFF80FF;
LC:= REF(C,1);
RSI1:=SMA(MAX(C-LC,0),6,1)/SMA(ABS(C-LC),6,1)*100,LINETHICK0,Precision1;
RSI2:=SMA(MAX(C-LC,0),12,1)/SMA(ABS(C-LC),12,1)*100,LINETHICK0,Precision1;
RSI3:=SMA(MAX(C-LC,0),24,1)/SMA(ABS(C-LC),24,1)*100,LINETHICK0,Precision1;
A3:=BARSLAST(REF(CROSS(RSI1,RSI2),1));
B3:=REF(C,A3+1)>C AND REF(RSI1,A3+1)<RSI1 AND CROSS(RSI1,RSI2),ColorWhite;
C3:=BARSLAST(REF(CROSS(RSI2,RSI1),1));
D3:=REF(C,C3+1)<C AND REF(RSI1,C3+1)>RSI1 AND CROSS(RSI2,RSI1);
RSI底背:=B3>0;
DRAWTEXT(B3>0,dif*1.05,'  R底背'),COLORred;{DRAWICON(B3>0,macd*1.2,1);{FILTER(B3>0,3),nodraw;
RSI顶背:=D3>0;DRAWTEXT(D3>0,dif*1.1,'R顶背'),ColorGreen;
 
STICKLINE(MACD>0 && REF(MACD,1)<MACD, MACD,0,0.11,0),COLORRED;
STICKLINE(MACD>0 && REF(MACD,1)>MACD, MACD,0,0.11,0),COLORYELLOW;
STICKLINE(MACD<0 && REF(MACD,1)<MACD, MACD,0,0.11,0),COLORMAGENTA;
STICKLINE(MACD<0 && REF(MACD,1)>MACD, MACD,0,0.11,0),COLORGREEN;

上一篇:飞狐源码:短线双龙,五龙起舞

下一篇:飞狐公式源码:擒大主力资金

推荐阅读
金冠BBIN电子开奖记录 爱博彩论坛登入 捷豹彩票平台怎么玩 787棋牌官網下載 澳门银河真人在线娱乐登入
沙龙娱乐开元棋牌 玛雅ag棋牌 41彩真人棋牌 乐橙棋牌883 万象城PT电子
金牛国际棋牌娱乐城 梦之城棋牌883 传奇棋牌娱乐 新葡京娱乐AB棋牌 黄金城MG电子
重庆时时彩开奖号码登入 新锦江MW电子 菲律宾太阳城申博7777 通博IM棋牌 奔驰娱乐欧博